1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still haven't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. Ride into the sunset with the 32nd Modeling Contest. The contest is optionally paired. Best of luck, people!
    Dismiss Notice
  4. This adventure has come to an end. Congratulate our heroes in the 16th Mini Mapping Contest Results.
    Dismiss Notice
  5. From the gates of hell, the 5th Special Effect Contest Results have emerged.
    Dismiss Notice
  6. Race against the odds and Reforge, Don't Refund. The 14th Techtree Contest has begun!
    Dismiss Notice
  7. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Importing issues

Discussion in 'World Editor Help Zone' started by Notusedbefore, Mar 2, 2009.

  1. Notusedbefore

    Notusedbefore

    Joined:
    Mar 2, 2009
    Messages:
    47
    Resources:
    0
    Resources:
    0
    I am working on a map of mine, currently, and I would like to import a few models and skins. Now I'm having a few issues with that. Starting off, I just got TFT recently. It's Editor is so much better than ROC, and I love it, but It's still a little overwhelming. I am having little trouble importing skins, but I am having issues with models.
    When I try to import a model, I put in the custom path which was given to me, but still, when I try to make a unit that model, it doesn't work. It encounters some error. Can I get some help with this?
    As well, I sometimes have trouble loading skins. Despite having the pathing right on, the skin doesn't load.... As well I am having trouble finding some paths. I cant really find a lot of them in my MPQ opening thing. A lot of them are stashed in areas like textures instead of Units...
    Can anyone help?
    [Edit] I forgot to mention that I have trouble with skins whose file names are not the same as the pathing unit's name... I dont know why...
     
  2. Ninja_Duels

    Ninja_Duels

    Joined:
    Aug 19, 2007
    Messages:
    297
    Resources:
    1
    Maps:
    1
    Resources:
    1
  3. cool_is_i

    cool_is_i

    Joined:
    Oct 23, 2007
    Messages:
    505
    Resources:
    8
    Maps:
    7
    Tutorials:
    1
    Resources:
    8
    aft u download you get the .mdx file
    -go to the import editor [a button on the top somewhere of the editor]
    -file > import file > import your .mdx file
    -double click and check the box that says use custom path
    -delete 'war3imported/' leave the rest
    -click ok
    -save your map
    -close [have to close] and open WE again
    -go to a unit in the object editor [another button on the top somewhere]
    -click a unit, go to model file, double click
    -select imported
    -select you imported model.mdx
    -finished
    -and credit the author

    this is for models,
    for skins, do the same but you have to replace the .mdl path in the import manager with the one given on the page you downloaded it from.