• 💀 Happy Halloween! 💀 It's time to vote for the best terrain! Check out the entries to Hive's HD Terrain Contest #2 - Vampire Folklore.❗️Poll closes on November 14, 2023. 🔗Click here to cast your vote!
  • 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 HD Level Design Contest #1 is OPEN! Contestants must create a maze with at least one entry point, and at least one exit point. The map should be made in HD mode, and should not be openable in SD. Only custom models from Hive's HD model and texture sections are allowed. The only exceptions are DNC models and omnilights. This is mainly a visual and design oriented contest, not technical. The UI and video walkthrough rules are there to give everyone an equal shot at victory by standardizing how viewers see the terrain. 🔗Click here to enter!

[Solved] Debugged successfuly but the game doesn't starts

Not open for further replies.
Level 12
Oct 16, 2010
I can't figure out what could be the problem.

I have a global integer array named Hero containing unit id's

I know this line cause the problem:

call CreateUnitAtLoc(Plyr,Hero[hrid],Location(300,300),270)

and if i directly write the units id in it, it works fine.
Plyr is a player variable works fine
Location works fine
the problem is in the "Hero[hrid]" part
hrid is an integer of course

Any idea? I save --> no errors --> run test --> and drops me in the main menu
tried to start the map directly but no change
Not open for further replies.