• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!

Custom Unit Sound Set?

Status
Not open for further replies.
Level 7
Joined
Mar 9, 2016
Messages
226
What I tried:
I tried replacing the unit sound set with an existing one, that didn't seem to work, whenever I run/try to test it replaces it back with the default sound. I tried something similar this way and it ended up having no sounds.

------------------
Complains about internet not having enough info about this:
I kept googling but I cant seem to find much about this besides the way to replace the unit sound set which isn't working otherwise it shows up world editor tutorial sites's homepages, etc.


Does anyone know how to create a custom unit sound set?
 
Level 7
Joined
Mar 9, 2016
Messages
226
I think you should not play any other maps before your test map. Playing any other map will set the soundsets "in stone" for the whole Warcraft III session, so you had to restart and play your test map as the first map.
I played the 'test map', through the world editor.
 
Level 11
Joined
May 16, 2016
Messages
730
I tried replacing the unit sound set with an existing one, that didn't seem to work, whenever I run/try to test it replaces it back with the default sound. I tried something similar this way and it ended up having no sounds.
Use any Media Editor and save sounds as .wav 8 bit 22050 hz. Then go to Sound Editor - right click, replace and choose a proper media file.
It works for me.
 
Level 7
Joined
Mar 9, 2016
Messages
226
Are you using the sound editor and right click replacing them,
the import manager or the campaign import manager?
I'm using the sound editor, right clicking and replacing them. Yes.

Use any Media Editor and save sounds as .wav 8 bit 22050 hz. Then go to Sound Editor - right click, replace and choose a proper media file.
It works for me.

Yep, using .wav
 
Status
Not open for further replies.
Top