[Solved] Command/Vampiric Aura not working on melee units

Level 30
Joined
Jan 31, 2010
Messages
3,581
Well, I just recently got this new error. Everything is fine and set-up at the Object Editor and Triggers, but the Vampiric Aura and Command Aura, which both affect melee units only - they are not working.
Could the problem be with corrupted data?
Do I need to start over with the map?

Stasus: Solved!
Issue: Setting Attack Type to instant counts the unit as ranged one. Wow.
 
Last edited:

Bannar

Code Reviewer
Level 26
Joined
Mar 19, 2008
Messages
3,140
Apheraz Lucent, could you please post map?
This problem looks wierd at least. However, check the "Targets Allowed" field for both abilities, plus make sure at least one of criteria listed there match unit's field: "Targetted as" (don't have eng WE; but basically it's how unit is treaten as target for other units).
 

Bannar

Code Reviewer
Level 26
Joined
Mar 19, 2008
Messages
3,140
There is an option is Trueshot Aura for that. Basically in Object Editor you can even make is avoid ranged units too.
Meaby you have based your auras on Trueshot Aura; just with differend appearance - in such case, there is nothing wierd with those affecting only range targets if OE field - 'Count Melee Units' is set to False and 'Count Range Units' to True.
 
Level 30
Joined
Jan 31, 2010
Messages
3,581
Everything is fine, I think.
Don't mind leaking, triggers un-set object & trigger data, and visuals. The map is still in heavy development, and I haven't even started a thread for it.
Also, please do not use and claim this map as yours.


I solved the problem. It appears that if you set your
Combat - Attack 1 - Weapon Type to instant, it counts units as ranged. Didn't know that, it can be quite useful, I think.
 
Top