1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. The poll for Hive's 12th Concept Art Contest is up! Go cast your vote for your favourite genie!
    Dismiss Notice
  4. Travel to distant realms and encounter scenes unknown to the common folk. The Greatest of Adventures is upon us with the 8th Cinematic Contest. Join in on a fun ride.
    Dismiss Notice
  5. The 18th Icon Contest is ON! Choose any ingame unit and give him/her Hero abilities. Good luck to all.
    Dismiss Notice
  6. Contestants are to create a scene set in the Stone Age. Come and see what you can come up with. We wish you the best of luck!
    Dismiss Notice
  7. Colour outside the lines! Techtree Contest #13 is a go. The contest is optionally paired.
    Dismiss Notice
  8. Greetings cerebrates, our Swarm needs new spawners that will have numerous children. Join the HIVE's 31st Modeling Contest - Spawners and Spawned! The contest is optionally paired.
    Dismiss Notice
  9. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

1.31.1 Bug - Saving Destroys AI in Custom Campaign

Discussion in 'Patch & Reforged Discussion' started by tulee, Aug 12, 2019.

  1. tulee

    tulee

    Joined:
    Jul 26, 2008
    Messages:
    803
    Resources:
    7
    Maps:
    7
    Resources:
    7
    Hi,

    I have noticed an issue where, if the game is saved (normally at the start of a campaign mission), the AI "breaks". Now what I mean by this is, the attack waves malfunction. They are perfectly able to rebuild destroyed buildings/dead troops, but they will never attack anyone.

    Interestingly, I was watching an ally AI behave, and it would actually ping the places it was trying to attack, but it would never send any men. This is really strange behaviour. Normally if an AI breaks, it completely breaks, but here everything except the AI attack waves functioned fine.

    When I did not save at the start of a mission, the AI worked perfectly normal with its attack waves.

    Was just wondering if anyone knew what was going on. If the entire AI was breaking, then there might be a plethora of potential causes, but in these cases only the attack waves were affected.
     
  2. deepstrasz

    deepstrasz

    Map Reviewer

    Joined:
    Jun 4, 2009
    Messages:
    10,243
    Resources:
    1
    Maps:
    1
    Resources:
    1
    We'd really appreciate a test map. Does it happen on older campaigns, any campaign, so on?