Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Texture Mapping endeavors not panning out, easier way? Please help.

Discussion in 'Warcraft Editing Tools' started by Goombah, Feb 25, 2020.

  1. Goombah

    Goombah

    Joined:
    Aug 27, 2007
    Messages:
    16
    Resources:
    0
    Resources:
    0
    long time lurker, first time poster. so, after much trouble i was able to convert a model to a working .mdx/.mdl file but the texture no longer fit on the model and after an hour trying to texture map it, it came out bad. some parts were good, others not. i feel like it'd be impossible to get it perfect using the MdlVis program. im savvy with computers and software but i only made 3d models in autodesk and that was years ago. appreciate the help, this is my favorite game of all time and would like to make my own original model and texture at some point. anyway, i hear there's a way to get the mapping through "unwrapping" the original model and applying it to the converted one but I don't know how to go about it. most of the posts on this stuff are from over 10 years ago, have any ease-of-use advancements been made since? oh and when trying to apply the texture with WC3ModelEditor, it doesnt work and then the file corrupts and cant be opened.

    It seems like something gets lost during the conversion process and the texture no longer works right.
    Is there possibly a way to automatically attach a texture to this converted model?

    The model is of Mario, I've attached a picture of what it looks like in the model editor and why. the only way i can get my badly mapped texture to work on worldedit is by changing the .blp to that exact filename and path as seen in the pic.

    Is there an easy way to convert a model to wc3, texture and all? Hivepost.png
     
    Last edited: Feb 25, 2020
  2. Goombah

    Goombah

    Joined:
    Aug 27, 2007
    Messages:
    16
    Resources:
    0
    Resources:
    0
    Great news! After hours of trial and error, I found a method that works. transferring the animations hasnt worked yet but i've got the model and texture working perfectly.

    If anyone comes here wondering how, I downloaded the 88mb Blender program v2.79 and the Blender Warcraft 3 Model .MDL Exporter. Applied the skin, gave it a path and exported it as .mdl. took the png and converted it to TGA 32 bit using (Online image converter to TGA - Free Online Converter) then converting the TGA to BLP using Warcraft III Viewer. Now all I have to do is point to the right path in worldedit and it works! although in t-pose. getting the animation transfer program to run was a pain too, had to get "comdlg32.ocx" and put it in syswow64 folder and system32. All worth it though, check it out in picture below. Worst comes to worst I can try n learn to make a simple attack animation.

    But since im already here, anyone know why my animation transfer didnt work?


    hivepost2.png

    edit: added in-game screenshot, btw no need for a converter. PrtScn copies the image so i just paste it into MS Paint.

    hivepost3.png
     
    Last edited: Feb 25, 2020