Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Site keeps crashing

Discussion in 'Site Discussion' started by Freyky, Jan 1, 2017.

  1. Freyky

    Freyky

    Joined:
    Aug 6, 2014
    Messages:
    87
    Resources:
    0
    Resources:
    0
    Hey, is this site style ever gonna change?
    Idk why but it keeps crashing my mozilla browser.
    Each time I leave this page open the tab is either crashing or the whole browser, someone knows a fix?
    Someone else has experienced this problem?
    Also this site is quite "laggy"
     
  2. At least I haven't experienced this, try updating Firefox and check if you can toggle hardware acceleration. Look how much RAM you got free as well.
     
  3. Heinvers

    Heinvers

    Arena Moderator

    Joined:
    May 7, 2010
    Messages:
    8,335
    Resources:
    83
    Models:
    2
    Icons:
    50
    Packs:
    3
    Skins:
    25
    Template:
    3
    Resources:
    83
    I wouldn't say laggy. I must be something on your end. I use Chrome and it runs smoothly.
    It must be something on your end, or the browser itself.
     
  4. deepstrasz

    deepstrasz

    Map Reviewer

    Joined:
    Jun 4, 2009
    Messages:
    15,419
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Reinstall your mozilla firefox but first try disabling all your plugins. I had crashes on a Blizzard.com's page and for some reason it worked after disabling everything.
     
  5. pyf

    pyf

    Joined:
    Mar 21, 2016
    Messages:
    2,689
    Resources:
    2
    Tutorials:
    2
    Resources:
    2
    You should not follow @LordDz's advice for obvious reasons.

    My suggestions:
    - launch your browser without any extension, by holding down the Shift key right after clicking on Firefox's icon
    - clear Firefox's internet cache, and restart the browser
    - uninstall/reinstall Firefox
    - try with another browser (like Pale Moon for example)
    - backup all your important data, and do a full scan of your HDD for bad sectors (requires a restart).
     
    Last edited: Jan 2, 2017
  6. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    26,128
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    Probably one of the adverts. Recently the engineering quality of adverts is atrocious with them using insane processor resources or having serious memory leaks. This is a problem with the adverts and not the browser as the same adverts cause the same problems in Edge as they do in Chrome.

    The adverts are localized and regional as many people might not experience the same problems.
     
  7. Freyky

    Freyky

    Joined:
    Aug 6, 2014
    Messages:
    87
    Resources:
    0
    Resources:
    0
    I don't think it's the browser, nor my PC.
    I've had theese "lags" for a longer time on hiveworkshop even on my old disk, but not the crashes tho.
    Never had lags on the old hiveworkshop design tho.

    Can't be mozilla either because I've wiped my disk and got a new one about a week ago and had a clean and fresh install of everything.

    Advertisement idk I'm using adblocker.


    Thank u all for ur great & fast responses except the one who basically told me to destroy my disk drive with a magnet.
     
  8. How about you pour water on the Computer and It'll go fast as light.
     
  9. Ralle

    Ralle

    Owner

    Joined:
    Oct 6, 2004
    Messages:
    11,462
    Resources:
    21
    Tools:
    2
    Maps:
    5
    Tutorials:
    14
    Resources:
    21
    The old design was much more CPU intensive because of the way the leaf borders were displayed. This one runs much smoother on mobile devices, etc. What kind of computer do you have?
     
  10. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    26,128
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    The site now uses some kind of streaming update notification system. I am guessing this requires a TCP connection be open or opened periodically? Maybe the site pages being browsed will hang for extended periods if the browser is having problems communicating through the TCP connection, eg if using unreliable or intermittent internet.
     
  11. TheLordOfChaos201

    TheLordOfChaos201

    Joined:
    Jul 2, 2011
    Messages:
    1,739
    Resources:
    0
    Resources:
    0
    I just notice on my phone the page often crashes on loading, double posts or doesn't post at all

    but I thought that was just my phone

    I use an android and my browser is a opera mini
     
  12. pyf

    pyf

    Joined:
    Mar 21, 2016
    Messages:
    2,689
    Resources:
    2
    Tutorials:
    2
    Resources:
    2
    @jondrean : page 82 is shock full of embedded YouTube videos. They do eat RAM; therefore a 1 GB RAM PC (or less) will choke and swap like crazy with this specific page. I am waiting for page 83, to post again in this thread.
     
    Last edited: Jan 2, 2017
  13. Freyky

    Freyky

    Joined:
    Aug 6, 2014
    Messages:
    87
    Resources:
    0
    Resources:
    0
    Some quite average one I guess, it's a little old but I keep buying a newer video card, CPU, motherboard, etc.
    I don't think that it's my PC tho, disk should be fine too since it's new / wiped & cleared.

    B85M-G Asus Motherboard
    16 GB Ram
    i5 3.30 GHz Dual Core
    Nvidia Geforce GTX 750
     
  14. deepstrasz

    deepstrasz

    Map Reviewer

    Joined:
    Jun 4, 2009
    Messages:
    15,419
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Sorry guys :( me fault. If you want me to remove the links, I wills.
     
  15. pyf

    pyf

    Joined:
    Mar 21, 2016
    Messages:
    2,689
    Resources:
    2
    Tutorials:
    2
    Resources:
    2
    @deepstrasz : posting links which open another Tab on YouTube, should fix the issue.
     
  16. deepstrasz

    deepstrasz

    Map Reviewer

    Joined:
    Jun 4, 2009
    Messages:
    15,419
    Resources:
    1
    Maps:
    1
    Resources:
    1
    How?
     
  17. pyf

    pyf

    Joined:
    Mar 21, 2016
    Messages:
    2,689
    Resources:
    2
    Tutorials:
    2
    Resources:
    2
    Last edited: Jan 2, 2017
  18. deepstrasz

    deepstrasz

    Map Reviewer

    Joined:
    Jun 4, 2009
    Messages:
    15,419
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Oh that... how stupid I am...

    EDIT: done, I think.
     
    Last edited: Jan 2, 2017
  19. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    26,128
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    Oh yes, I forgot that every time someone links a youtube the page hangs while the youtube widget is loaded. We had that with one of the blizcon news posts where the moderator linked 40 odd youtube videos so loading the site main page took ~30 seconds.

    I think Google has been working to fix this though by making a lighter weight widget that does not need to be resolved through them before it can be used.