1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. We have recently started the 16th edition of the Mini Mapping Contest. The theme is mini RPG. Do check it out and have fun.
    Dismiss Notice
  4. Dismiss Notice
  5. The Highway to Hell has been laid open. Come along and participate in the 5th Special Effect Contest.
    Dismiss Notice
  6. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

[Crash] Freeze / Crash issue on loading

Discussion in 'World Editor Help Zone' started by maddeem, Nov 20, 2019.

  1. maddeem

    maddeem

    Joined:
    Jan 1, 2011
    Messages:
    1,272
    Resources:
    5
    Maps:
    2
    Spells:
    3
    Resources:
    5
    So I'm looking for help / opinions on what map be causing a crash.

    Description of the crash:
    Game client freezes when the map finishes loading and never unfreezes. Occurs randomly ONLY in multiplayer games. This does not affect all players.

    Map Link

    The main suspect is, however, removing the creation of the sound still causes a crash:
    Code (Text):

    //! inject config  
    local sound s=CreateSound( "LobbyMusic3.mp3", true, false, false, 10, 10, "DefaultEAXON" )
        call SetMapName("TRIGSTR_003")
        call SetMapDescription("TRIGSTR_005")
        call SetPlayers(24)
        call SetTeams(24)
        call SetGamePlacement(MAP_PLACEMENT_TEAMS_TOGETHER)
        call DefineStartLocation(0, 6592.0, 7232.0)
        call DefineStartLocation(1, 6592.0, 7232.0)
        call DefineStartLocation(2, 6592.0, 7232.0)
        call DefineStartLocation(3, 6592.0, 7232.0)
        call DefineStartLocation(4, 6592.0, 7232.0)
        call DefineStartLocation(5, 6592.0, 7232.0)
        call DefineStartLocation(6, 6592.0, 7232.0)
        call DefineStartLocation(7, 6592.0, 7232.0)
        call DefineStartLocation(8, 6592.0, 7232.0)
        call DefineStartLocation(9, 6592.0, 7232.0)
        call DefineStartLocation(10, 6592.0, 7232.0)
        call DefineStartLocation(11, 6592.0, 7232.0)
        call DefineStartLocation(12, 6592.0, 7232.0)
        call DefineStartLocation(13, 6592.0, 7232.0)
        call DefineStartLocation(14, 6592.0, 7232.0)
        call DefineStartLocation(15, 6592.0, 7232.0)
        call DefineStartLocation(16, 6592.0, 7232.0)
        call DefineStartLocation(17, 6592.0, 7232.0)
        call DefineStartLocation(18, 6592.0, 7232.0)
        call DefineStartLocation(19, 6592.0, 7232.0)
        call DefineStartLocation(20, 6592.0, 7232.0)
        call DefineStartLocation(21, 6592.0, 7232.0)
        call DefineStartLocation(22, 6592.0, 7232.0)
        call DefineStartLocation(23, 6592.0, 7232.0)

        // Player setup
        call InitCustomPlayerSlots()
        call InitCustomTeams()
        call InitAllyPriorities()

    call ClearMapMusicBJ(  )
    call StopMusicBJ( false )
    call VolumeGroupSetVolumeBJ( SOUND_VOLUMEGROUP_AMBIENTSOUNDS, 0.00 )
    call VolumeGroupSetVolumeBJ( SOUND_VOLUMEGROUP_MUSIC, 0.00 )
    call SetSoundDuration(s, 154357)
    call SetSoundChannel(s, 14 )
    call SetSoundVolume(s, 100 )
    call SetSoundPitch(s, .5 )
    call StartSound(s)
    set s=null

    //! endinject
    Any assistance resolving this issue would be greatly appreciated.