• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

[Solved] Crazy bug in the World Editor

Not open for further replies.
Level 4
Dec 1, 2008
Hello. I'm having a problem in world editor. I cannot change the user from player properties to be different color. For example by default you're player 1 red but I wanted to be player 2 blue so I changed player 2 blue to user and player 1 red to computer. But when I start the map I am still player 1 red. Whatever I do I am always the red player. I thought it was from the few triggers I used that have absolutely nothing to do with player properties and stuff, so I opened a new map and just placed 2 start locations for red and blue, changed the user to blue and set red as computer, started the map. And I was still player 1 red, oh and also even though player 2 race was orc, his start location was undead necropolis with 3 acolytes and 1 ghoul. Another thing I tried was set everything to none except blue to be the user (me). Started the map and the units I placed for player 2 blue had red color and I was still player 1 red.

What the hell is going on? I've never had this problem before. I never messed with warcraft 3 files except for extracting the RoC and TFT campaign maps but that was long ago, I've never had this problem before. I restarted World Editor, I even restarted my PC to see if this will fix the problem but it did not. Help please.

It seems by changing the Force Properties to Use Custom Forces and Fixed Player Setting fixed the problem. Sorry for starting this thread :ugly:
Last edited by a moderator:
Not open for further replies.