1.28.5 not working

I'm trying to run 1.28.5 on Windows 10 x64, but I get the error "Couldn't open Game.dll", even though Game.dll is in there. It's the one you can download from WC3 Download Archive (1.00 - 1.31.1 + BETA & DEMO).

When I try to run the WE, I get the error "Cannot find appropriate CD keys". Weirdly, I can run WEX, but obviously can't test maps.

I've tried putting it Program Files (x86)\Warcraft III, and I deleted all the Blizzard registry keys.
Running it in compatibility mode and/or as admin doesn't help.
Also tried manually setting the correct path in regedit.

Any idea how I can fix this?
 
Last edited:
Level 13
Joined
Feb 25, 2013
Messages
202
Cannot reproduce, also Win10x64, it runs without any issue and the file checksums of both the game.dll and Warcraft III.exe match my personal backups; did you try renaming/deleting the "Documents\Warcraft III" folder since 1.28 is hardcoded to try and copy all user data in there while not expecting it to exist. Sha1 of the game.dll is "7ED06CEDB40D4AD783FDA8265891040F54EF5602" generated via 7zip
 
Top