Warcraft 3 Black Screen Bug

Level 8
Joined
May 14, 2021
Messages
106
Hi, recently I downloaded the latest version of Warcraft 3 (1.31.1) here because some of the custom campaigns require the latest patches in order to play. However, it turns out that my game got bugged up. When I finished playing the Custom Games, the game freezes with black screen every time when I pressed "OK". As a result, I have to log out my Windows in order to fix this problem. I even tried closing my game using "Exit Game", but the result is same: The game always freezes for a short period of time until I decided to terminate it using Alt+Tab. This is shame because I even launched the game using "-windowmode fullscreen -graphicsapi Direct3D9" flag, which is the only way to solve the graphical problem. I'm quite new to this site. Could you help me with solving this problem? Cause I don't want 30 GB download of Reforged, which doesn't have custom campaigns, and that custom campaigns are really amazing and yet I can't enjoy the new features for 1.31.1 😀
 
Level 22
Joined
Sep 28, 2004
Messages
1,185
As a campaign creator I realized this black screen problem with 1.31 for the first time... It showed me that my maps were leaking, which technicall means, that I had many triggers that were writing to the PC's memory and that memory never got released. What I'm basically teling you here is, I don't think you, as a player, can do anything about that, except to wait a very long time until the game quits normally. Creators have to fix their maps.
 
Level 8
Joined
May 14, 2021
Messages
106
As a campaign creator I realized this black screen problem with 1.31 for the first time... It showed me that my maps were leaking, which technicall means, that I had many triggers that were writing to the PC's memory and that memory never got released. What I'm basically teling you here is, I don't think you, as a player, can do anything about that, except to wait a very long time until the game quits normally. Creators have to fix their maps.
Yeah, this problem only occurs when I played the map for about long time (a couple of minutes). The only way to solve the issue was actually restarting my computer, but sometimes, the game will close if I kill it manually from Task Manager (by clicking on "X" button several times).
I also tried using x86 folder, but the result is same.
 
Top