• 💀 Happy Halloween! 💀 It's time to vote for the best terrain! Check out the entries to Hive's HD Terrain Contest #2 - Vampire Folklore.❗️Poll closes on November 14, 2023. 🔗Click here to cast your vote!
  • 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 HD Level Design Contest #1 is OPEN! Contestants must create a maze with at least one entry point, and at least one exit point. The map should be made in HD mode, and should not be openable in SD. Only custom models from Hive's HD model and texture sections are allowed. The only exceptions are DNC models and omnilights. This is mainly a visual and design oriented contest, not technical. The UI and video walkthrough rules are there to give everyone an equal shot at victory by standardizing how viewers see the terrain. 🔗Click here to enter!

[Solved] Unit is not receiving upgrade?

Not open for further replies.
Level 7
Dec 29, 2008
Okay, this issue is really getting on my nerves right now. I am about 98% complete with my map, but this ONE problem is keeping me from it.

I created two upgrades, based off of cannibalize and some other upgrade, that allowed the building of certain structures. I had some triggers with chat commands that allowed these to be researched in a dummy unit. For some reason, they didnt work with the triggers, so i remade the upgrades, the unit, and applied them to everything, except this time i made it so that i could see the dummy unit that had the upgrade in it. I tested the map, used the chat commands, and nothing. After that, i selected the unit with the upgrade, and guess what? It didnt have the upgrades at all! i checked the object editor but it showed that the unit did INDEED have them, it just wasnt showing up ingame.

I am in a state of "WTFHAX" at the moment due to complete confuzzlement. I have no idea what to do with this problem, so i'm asking you guys for help. First to solve this gets +rep

EDIT: solved
Last edited:
Not open for further replies.