Need help with quests

Not open for further replies.
Level 2
Jul 22, 2011
Hello, so i have been working on my rpg project and i made a few quests and here is the problem, i wasted 2 hours and haven`t solved it because i am a noob. So here is the thing i made 3-4 quests.
I start at a zone, i get a quest to talk to an npc, so i do this i make a quest.
I use open new category, then new trigger then i use time elapsed set it to 0.00
then i use action quest, btw i used when ever i finish quest i make a cinematic:goblin_yeah:
So to cut it short i made it to go to npc,then npc gives me the quest to kill a unit, then get a quest to return to him. And there is the problem, i used for both cinematic the same command. Cinematics of taking quest and cinematics of returning quest. I probably made a noob mistake, anyway quests and cinematics work, but i used event Unit- Specific unit event, i used unit npc, and command i used is selected. It all worked before i made another cinematic. I know i made it hard to understand but pls help i am desperate, what is the other option? This happens when i start i get the quest to talk to npc and then i select npc and i get second cinematic not first, pls i know it is not a big problem i just don`t know how to solve it pls help!!!!
Not open for further replies.