• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!

Custom Map Preview

Status
Not open for further replies.
Level 3
Joined
Jul 16, 2014
Messages
63
Hey guys.

I have been using the forums hiveworkshop for years, but this is the first time I have ever made a user here. So first of all, hello to everyone :)

I am currently working on a map, and I have a really annoying problem.
When trying to make a Custom Map Preview, I just can't seem to get it right. The closest I have been to getting it to work, was that the questionmark in-game dissappeared, but nothing showed instead.

I have been searching google, hiveworkshop, the-helper and such for several hours and I keep getting different answers.. And it seems like no matter what I try, the result is the same...

So first of all, I would like it if someone could give me the facts straight:

File type:
TGA - This is the one I have heard the most. But I have also heard that it needs to be 32 bit. Have also heard that if it isn't 32 bit, it just needs an alpha channel. Would like this confirmed. Last theory is that it doesn't matter, yet most guides seem to leave this stuff out.
BLP - Does BLP even work or is the preview TGA only? If it does, does it need to be 32 bit or no?

Picture size:
128x128
256x256
512x512
Got my map preview in all 3 sizes. 256x256 is the one I have been working with, but I would like a confirmation.

Custom path:
war3mapPreview.tga/blp
War3mapPreview.tga/blp
Have encountered both, but none of them seems to take the cake.

Step by step process of what I do.
1: Make a blank picture in Photoshop CS6 Extended in the desired size(128x128, 256x256, 512x512), RBGColor 8bit.
2: Make the gfx.
3: Save as TGA file, 32 bit(24 bit is available aswell).
4: Save the map with desired custom path.
(4.1: Open tga file in Warcraft III viewer to convert to BLP)
5: Import into map with desired custom path.
6: Chill all day, cause nothing happens lol.

Anyone who can tell me what I am doing wrong?
 
Level 25
Joined
Jul 10, 2006
Messages
3,315
I'm using
Size: 256x256
File type: .tga
Path: war3mapPreview.tga

Your settings appear to be right, so the problem is probably with your conversion.

I'm using IrfanView - http://www.irfanview.com/main_download_engl.htm
1. Make image
2. Open in IrfanView
3. Resize to 256x256 if necessary
4. Save as .tga
5. Import

Also, make sure that "Hide minimap in preview screens" is unticked.
 
Level 3
Joined
Jul 16, 2014
Messages
63
Use the 128x128 picture size (It's smaller in filesize and the difference in pixels is hardly noticable), I use GIMP for my picture file conversions , import the picture with the World Editor import manager, and set the files path to
"war3mapPreview.tga", do not put "/blp" at the end.

I didn't put /blp at the end. That was to suggest the possibility of blp files working aswell.

I'm using
Size: 256x256
File type: .tga
Path: war3mapPreview.tga

Your settings appear to be right, so the problem is probably with your conversion.

I'm using IrfanView - http://www.irfanview.com/main_download_engl.htm
1. Make image
2. Open in IrfanView
3. Resize to 256x256 if necessary
4. Save as .tga
5. Import

Also, make sure that "Hide minimap in preview screens" is unticked.

You sir, is a champ. I must be a total moron for not realising this myself, but not a single place have I seen it mentioned that "Hide minimap in preview screen" should be unticked. lol
 
Level 3
Joined
Jul 15, 2014
Messages
44
I'm using
Size: 256x256
File type: .tga
Path: war3mapPreview.tga

Your settings appear to be right, so the problem is probably with your conversion.

I'm using IrfanView - http://www.irfanview.com/main_download_engl.htm
1. Make image
2. Open in IrfanView
3. Resize to 256x256 if necessary
4. Save as .tga
5. Import

Also, make sure that "Hide minimap in preview screens" is unticked.

Thanks i was try many time, and after I see your preview and wow its working.. i really like it and thanks (*⌒▽⌒*)

1) need to custom path: Path: war3mapPreview.tga
2) unchecked "Hide minimap in preview screens" at map options ♪(*^o^)/\(^-^*)
 
Status
Not open for further replies.
Top