[Log in / Register]
| News | Chat | Pastebin | Donations | Tutorials | Rules | Forums |
| Maps | Skins | Icons | Models | Spells | Tools | Jass | Packs | Hosted Projects | Starcraft II Modding | Starcraft II Resources | Galaxy Wiki |
(Keeps Hive Alive)
Go Back   The Hive Workshop > StarCraft II > StarCraft II Editor Help Zone > Graveyard


Graveyard Unsolved or abandoned threads are moved here if no solution is found.

Closed Thread
 
Thread Tools
Old 01-05-2012, 04:19 PM   #1 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
How to set player slots to computers and lock them?

I want players 1-3 to be user controlled in a team and players 11-14 to be computer controlled. I've set 1-3 to be USER controlled in Player properties and 11-14 to be computer controlled, but nothing like that is happening. When I test the map in Battle.net I see 7 free spaces in 7 different teams. Can someone help me please, I dont know what to do :/
P.S. I said that in BN I have 7 free spaces. Yeah, no matter which I choose to play from I wind up as Player 1.
P.P.S. I solved it for now by setting 11-14 computer controlled slots to be controlled by no one. Is there another way? And how do I arrange teams? Strange.. I got to understanding the Data editor pretty well, I make sick trigger but I cant arrange teams and make computer controlled slots :D
P.P.P.S. Looks like that my last action of setting computer controlled players to be controlled by nothing has made my map a mess and the alliances that the game arranges with triggers written by me no longer work.
Br3akth3w1nd is offline  
Old 01-05-2012, 07:23 PM   #2 (permalink)
Registered User Dr Super Good
Imperial Good
 
Dr Super Good's Avatar
 
Join Date: Jan 2005
Posts: 17,373
Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)
Former Staff Member: This user used to be on the Hive Workshop staff. Merit Badge - Level 0: This user has proven to be extremely valuable to the Warcraft III Modding Community. User of the Year: 2010 
Remember that game variences have an effect on slot status. When playing custom it defaults to the custom varient which has customizable teams. You need to set it to the custom game varient you set up before starting the game. Variences can not be changed when a game is public.
Dr Super Good is offline  
Old 01-06-2012, 10:33 AM   #3 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
Oh yeah thanks! I was searching for that but didnt know it was there ^_^
Br3akth3w1nd is offline  
Old 01-06-2012, 12:12 PM   #4 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
Hmm I made a new game Variant and did everything like I wanted to since none of the other variants locked the computer slots. Now when I try to access my map in Bnet it says that there is a temporary problem with my request. :? Why? What did I do wrong? Ive set the custom variant to Melee - FFA and locked all the teams.
Edit: Nop.. I have no idea how to make teams and computer controlled locked slots to match my map needs. How do other map makers do it?
Edit2: This was so much easier in sc1 and wc3, I am ready to quit right now, because I tried everything.

Last edited by Br3akth3w1nd; 01-06-2012 at 12:55 PM.
Br3akth3w1nd is offline  
Old 01-06-2012, 02:25 PM   #5 (permalink)
Registered User Dr Super Good
Imperial Good
 
Dr Super Good's Avatar
 
Join Date: Jan 2005
Posts: 17,373
Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)
Former Staff Member: This user used to be on the Hive Workshop staff. Merit Badge - Level 0: This user has proven to be extremely valuable to the Warcraft III Modding Community. User of the Year: 2010 
Quote:
Hmm I made a new game Variant and did everything like I wanted to since none of the other variants locked the computer slots. Now when I try to access my map in Bnet it says that there is a temporary problem with my request. :? Why? What did I do wrong? Ive set the custom variant to Melee - FFA and locked all the teams.
You have made a logical error in your Game Varients. Thus they are unable to be resolved and so BattleNet throws you an error. When editing gameplay varients you need to change only a few fields at a time and test if they still are resolved.

Locking fields in gameplay varients is especially prone to this type of error. Use locks sparingly.
Dr Super Good is offline  
Old 01-07-2012, 03:27 PM   #6 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
Lawl thanks I did it! Also I saw that in the lobby I can choose Teams: 2v2, 3v3 etc. The default is 2v2 and thats the one I want, how can I lock this bar?
P.S. Oh yeah, there is an option to lock teams. My editor is a little buggy and didnt show it before...
Br3akth3w1nd is offline  
Old 01-07-2012, 03:49 PM   #7 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
Problem. It looked like I had fixed them and I published a non-private version. They dont work in it. The game variants are just the same, except when I published it in private mod there is no error and the map is fine. In public mode however the problem persists.
Br3akth3w1nd is offline  
Old 01-07-2012, 09:30 PM   #8 (permalink)
Registered User Dr Super Good
Imperial Good
 
Dr Super Good's Avatar
 
Join Date: Jan 2005
Posts: 17,373
Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)Dr Super Good has been here far too long (3180)
Former Staff Member: This user used to be on the Hive Workshop staff. Merit Badge - Level 0: This user has proven to be extremely valuable to the Warcraft III Modding Community. User of the Year: 2010 
Quote:
Problem. It looked like I had fixed them and I published a non-private version. They dont work in it. The game variants are just the same, except when I published it in private mod there is no error and the map is fine. In public mode however the problem persists.
I am sorry but this problem is a little bit beyond my experience. They have overhauled the system a bit since I last published something. All I can tell you is that publication was a major trial and error process and I had to publish my map 11 times before the results were satisfactory.

Start by reseting the varients to what you orignally had. Then change fields a few at a time until you get the satisfactory results. It does not mater if you do all this while the map is public as the chance of someone actually playing it while you do this processes are minimal if you do not advertise.
Dr Super Good is offline  
Old 01-08-2012, 03:53 PM   #9 (permalink)
Registered User Br3akth3w1nd
User
 
Br3akth3w1nd's Avatar
 
Join Date: Aug 2008
Posts: 118
Br3akth3w1nd has little to show at this moment (8)
Ok, thanks for the advice :)
Br3akth3w1nd is offline  
Closed Thread

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT. The time now is 03:20 PM.




Powered by vBulletin
Copyright 2000 - 2008, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.1 PL2
Copyright © Ralle