War3 Model Editor Wont Load Textures

Level 9
Joined
Sep 25, 2013
Messages
480
For both war3 model editor and Warcraft 3 viewer textures wont load. How do i get textures to load? Thank you for your time

full


Does it have something to do with MPQ's? I don't know what MPQ stands for or its function and I haven't been able to find any clear information when i try look it up.
 
Last edited:
Level 10
Joined
Feb 25, 2013
Messages
118
War3 model editor is very old and as such does not find any version after about 1.26, plus or minus 2 versions, so it might be worth it to look into any of the more up to date software.

If you do decide to continue using it, there are 2 cases you will have to consider:
1) If the version you currently have is older than 1.30, you will have to copy all the MPQ files located inside of the Warcraft III folder into the folder where you installed the War3 model editor
This can also be done by moving the War3 model editor into the Warcraft III folder but that will make it look messy and as such I highly discourage that
2) If you don't have a version older than 1.30, you will not be able to get textures to display in War3 model editor. As a post-scriptum for this case - 1.32 models cannot be opened by the old tools anyway so if you have to interact with those in any way, you will have to find a tool that is not as ancient
 
This can also be done by moving the War3 model editor into the Warcraft III folder but that will make it look messy and as such I highly discourage that
This is what I do, personally I find it the best way to go about it. Just make sure you don't overwrite any of the DLLs.

If you aren't using an old version of WC3 which has the MPQs, you can download one from here: WC3 Download Archive (1.00 - 1.31.1 + BETA & DEMO)
If you're not using it, you can just put the MPQs in the Magos folder and delete the rest of the files.
 
Top