Units Moving Slow...

Level 8
Joined
Feb 17, 2007
Messages
368
Not sure why but I just created a new map and copied over 1 of my units from another one of my maps, and for some reason in the new map the unit moves really slowly, even though it has the same movement speed as in my other map. The game speed is set to fast, so that's not the problem. In the gameplay constants the values are the same: Minimum 150, Max 400. The units move speed is 220 but it is definitely not moving at that speed. When I bump it up to around 400 or so it increases to where it should be, like in my other map. Any ideas as to what the problem is?
 
Level 9
Joined
Dec 21, 2011
Messages
332
Wut.

Q & A for your units;

Are you sure game speed is set to fast?

Try making the movement speed : 1000 for a unit. If still moves slow try this:

Try a blank map and put a identical unit(s); If unit moves nicely, there's a problem on the current map.

~Da Fist~
 
Level 33
Joined
Mar 27, 2008
Messages
8,035
Nup.

Hold+Shift+Click = Bigger amounts w/ larger limits

Say - 522 is the max speed right?

Hold+Shift+Click = 522 or more.

Eventhough you can "cheat" the system in Object Editor and Gameplay Constants, the game is hard-coded and is set to default max speed of 522 (even you have value higher than that, you still can't go beyond 522 of movespeed, unless a system (Trigger Editor) plays its role)

If you still don't believe this, try set the unit movespeed to 1000 and use this to detect

  • Game - Display to (All players) the text: (String((Integer((Current movement speed of Paladin 0000 <gen>)))))
It will still display 522 as the movespeed of a unit that have >522 movespeed
 
Top