1. Find your way through the deepest dungeon in the 18th Mini Mapping Contest Poll.
    Dismiss Notice
  2. A brave new world lies beyond the seven seas. Join the 34th Modeling Contest today!
    Dismiss Notice
  3. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
Hive 3 Remoosed BETA - NOW LIVE. Go check it out at BETA Hive Workshop! Post your feedback in this new forum BETA Feedback.
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Skin displays ok in WC3 Viewer, but bugs in WE

Discussion in 'Texturing & Surfacing' started by Gjallarhorn, Aug 14, 2009.

  1. Gjallarhorn

    Gjallarhorn

    Joined:
    Feb 1, 2009
    Messages:
    107
    Resources:
    0
    Resources:
    0
    ok, i've made this model and its texture, and as you can see it displays alright in the wc3 viewer. but after i import it in the World Editor, the skin displays kinda inside out or something... :

    [​IMG]

    How do I fix this?
     
  2. madqc

    madqc

    Joined:
    May 3, 2009
    Messages:
    214
    Resources:
    0
    Resources:
    0
    are you sure that there is no backfaces on your model? backfaces are invisible ingame.
     
  3. Gjallarhorn

    Gjallarhorn

    Joined:
    Feb 1, 2009
    Messages:
    107
    Resources:
    0
    Resources:
    0
    So, basically, it may be that I created it all inside out in 3D Studio? I don't understand how have I done this... In 3ds, as you create the faces, the bright red face is the front face and the darker red face is the back, right?
     
  4. Kuhneghetz

    Kuhneghetz

    Joined:
    Jul 27, 2004
    Messages:
    3,589
    Resources:
    230
    Models:
    119
    Icons:
    99
    Packs:
    3
    Skins:
    7
    Maps:
    1
    Template:
    1
    Resources:
    230
    I'm guessing the materials were automatically set to blend for some reason.

    Possible solution:
    1. Download this software.
    2. Run the model using that software.
    3. Click on Windows and choose Material Manager.
    4. When editing the materials that uses the model's custom skin, change the filter mode to None or Transparent.
    5. Save the model and test it in WE.
     
  5. Gjallarhorn

    Gjallarhorn

    Joined:
    Feb 1, 2009
    Messages:
    107
    Resources:
    0
    Resources:
    0
    Didn't work =/
    That filter was already set to None. I also tried setting it to transparent but neither of those worked.
    One thing: I editted the actual .mdl file myself to add the texture. Maybe I did something wrong?

    I'll attach the .mdl file.
     

    Attached Files:

  6. Bloody_Turds

    Bloody_Turds

    Joined:
    Jan 23, 2007
    Messages:
    1,266
    Resources:
    16
    Models:
    14
    Packs:
    1
    Tools:
    1
    Resources:
    16
    All the faces are facing backwards, I dont know how to "properly" fix it, but you can always set the texture to 2 sided, here ya go.. (that means its still rendering on the inside)
     

    Attached Files:

  7. Gjallarhorn

    Gjallarhorn

    Joined:
    Feb 1, 2009
    Messages:
    107
    Resources:
    0
    Resources:
    0
    thank you, thats good to know :D
    It partially solves the problem, yea... but would be nice to know what I've done wrong, because I don't wanna have to use double sided textures everytime I model...
     
  8. Bloody_Turds

    Bloody_Turds

    Joined:
    Jan 23, 2007
    Messages:
    1,266
    Resources:
    16
    Models:
    14
    Packs:
    1
    Tools:
    1
    Resources:
    16
    well its a problem with some export scripts, if you can invert all of the faces, in your program, then export to .mdl that should fix it XD, ofc im sure theres a better way..., but im sure most modeling software have an invert faces function