1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. We have recently started the 16th edition of the Mini Mapping Contest. The theme is mini RPG. Do check it out and have fun.
    Dismiss Notice
  4. Dismiss Notice
  5. The Highway to Hell has been laid open. Come along and participate in the 5th Special Effect Contest.
    Dismiss Notice
  6. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

How to make unit not leave footsteps?

Discussion in 'World Editor Help Zone' started by Murmeli, Aug 9, 2008.

  1. Murmeli

    Murmeli

    Joined:
    Feb 16, 2007
    Messages:
    31
    Resources:
    0
    Resources:
    0
    So, I have a custom model, or not actually model but when I type a code in my map I get a phoenix attachment to my feet so it looks like I'm riding it, but when I got the mount, it makes me another builder which has movement type hover and peasant model, animation speed 0 so it doesnt look like he is walking in the air. But when the animation speed is 0 the footsteps appear in the air where my peasant moves and there is like 100 footsteps so it looks like its one solid big trail, how to remove the footsteps?
     
  2. YoshiRyu

    YoshiRyu

    Joined:
    Jun 26, 2007
    Messages:
    686
    Resources:
    0
    Resources:
    0
    the 0's frame of the animation of the peasant should be one where one of its feet touch the ground, by stopping the animation on this frame, you make the model create a footstep during each frame of the game

    it's just a supposition, but i think that you can avoid this by setting the animation'speed to 0 after having let the peasant play some few frames (so it will stop on an other frame, a one which doesn't create footstep)
     
  3. Murmeli

    Murmeli

    Joined:
    Feb 16, 2007
    Messages:
    31
    Resources:
    0
    Resources:
    0
    Meh, that would be too hard, isn't there any easier solution?
     
  4. Need_O2

    Need_O2

    Joined:
    Aug 24, 2007
    Messages:
    2,880
    Resources:
    0
    Resources:
    0
    Footsteps are event objects inside model so you need to edit model for that
    get war3 model editor open your model
    Windows -> Node Manager
    there are things with camera icon in nodes which are events
    the even you are looking for should show FTP (footprint) at type in window that appears when you double click on it
    delete that event and no more footprints
     
  5. YoshiRyu

    YoshiRyu

    Joined:
    Jun 26, 2007
    Messages:
    686
    Resources:
    0
    Resources:
    0
    i've said something wrong, i didn't know that footsteps were in the unit's model
     
  6. Murmeli

    Murmeli

    Joined:
    Feb 16, 2007
    Messages:
    31
    Resources:
    0
    Resources:
    0
    Fixed it, I made a phoenix with a peasant on its back instead of a peasant with a phoenix on his feet. Thanks all.