How can I revert to an older warcraft patch?

Level 12
Joined
Dec 2, 2016
Messages
734
I tried this video


But when I run the program it can't find Warcraft III even when I select the folder it's stored inside.
My Warcraft is located in Program filesx86.

Any idea how else I can revert to an older patch or how to fix this issue?
 
Level 12
Joined
Dec 2, 2016
Messages
734
I had this issue once and the Warcraft folder most be located within Patch 1.26and patch 1.27 or else it won't work

Tell me your verison.

I'm currently on the most recent patch 1.30 I believe it is. Are you saying I should move the wc3 folder from program files to the wvs folder? : Screenshot - 4502726ad515f49f328fa2bb0edc79f6 - Gyazo

Do I need to first extract the patch folders? Because the video said not to.

Screenshot - 77d7fe42a8e58c6fa787ae241d90e221 - Gyazo
 
Level 8
Joined
Jul 10, 2018
Messages
383
I'm currently on the most recent patch 1.30 I believe it is. Are you saying I should move the wc3 folder from program files to the wvs folder? : Screenshot - 4502726ad515f49f328fa2bb0edc79f6 - Gyazo

Do I need to first extract the patch folders? Because the video said not to.

Screenshot - 77d7fe42a8e58c6fa787ae241d90e221 - Gyazo
nonono you don't have to move it to Wvs folder what i meant it's must be that your WC3 Folder is missing something because it's Supposed to say Successful switched or somethin like that.

and can you give me your Wc3 folder? like screenshot it for me i want to see it full
 
Level 2
Joined
Jan 5, 2022
Messages
14
That's one way to revive an old thread.


?????
Why would you ever want to go to 1.07? That's an old ass version that literally no one plays.
Well in the end I didn't need any help. I just wanted to see how different some maps were. I have both Reforged and 1.26 on another device
 
Level 19
Joined
May 14, 2021
Messages
522
Is there any way to go from 1.26 to 1.07 in one step?
Well in the end I didn't need any help. I just wanted to see how different some maps were. I have both Reforged and 1.26 on another device
Dude, you must ask any problems relating to Warcraft III here:

Starting from 1.21b (2008), the game no longer requires an original CD to play. If you attempt to install both 1.07 and any of the latest versions of WC3 that don't use the CD-based DRMs (deprecated in Windows 10/11), you might encounter numerous issues with the game.
However, you can still install multiple versions of WC3 (1.26-1.31) as Bogdan said, provided you have a separate game folders.
If you still want to test out 1.07 with any existing WC3 versions patched to the latest, download and install both 1.00 (ROC) and 1.07 (TFT) from the thread above. Remember to clear out any existing WC3 registries before installing.
 
Level 28
Joined
Feb 27, 2007
Messages
4,115
An aside, but it's relevant: 1.24b broke almost every map ever made by removing the return bug, so any map made before that patch would simply be unplayable on any patch after it, and any map written after 1.24b would not be loadable in any version prior to 1.24b. It's a hard wall in both directions.
 
Level 19
Joined
May 14, 2021
Messages
522
An aside, but it's relevant: 1.24b broke almost every map ever made by removing the return bug, so any map made before that patch would simply be unplayable on any patch after it, and any map written after 1.24b would not be loadable in any version prior to 1.24b. It's a hard wall in both directions.
In addition to fixing the "return bug", which makes all older maps unplayable on latest patches, I heard that some older WC3 modding tools that are designed for WC3 prior to 1.24 don't correctly work on the latest patches. You can't even insert the JJCP/NZCP on the older maps (1.23) because all available cheatpacks from WC3Edit.net require a working JASS Hashtable, which is added in 1.24.
 
Top